Have you ever wondered who is in your 2nd-degree network? With Explore, you can find out! We help you discover, browse, search, and follow people who are just one connection away.

We do this through email and twitter. By parsing the people you already know well (your existing connections), we surface people that you might already know, could get introduced to, or share similar interests & locations.

Because we're deeply integrated with Twitter, we help you follow them directly on twitter as well as reach out to ask for introductions. It's because of this deep integration that Explore requires a twitter account.

Brought to you by the Orchard team (www.orchard.ai)

-----------------------------------
Using Explore by Orchard requires the connection of your twitter account, and optionally, a Google or Microsoft based email account.

Our promise:
- We never read or store the contents of your email messages or DMs.
- We never email, post, tweet, or contact anyone without your consent.
- We never sell or share your data to anyone, ever.
- You can delete your account and all your data at any time.

Learn more at https://orchard.ai/privacy/
Read more
Loading...

What's New

Launching!
Read more

Additional Information

Updated
April 19, 2018
Installs
10+
Current Version
1.0.16
Requires Android
4.4 and up
Content Rating
Everyone
Permissions
Offered By
Preposterous Inc.
Developer
301 W Grand Ave #160 Chicago, IL 60654 United States Of America
©2018 GoogleSite Terms of ServicePrivacyDevelopersArtistsAbout Google
By purchasing this item, you are transacting with Google Payments and agreeing to the Google Payments Terms of Service and Privacy Notice.