LiteSabre Messenger

Versions less than 2.0.8 will stop getting notifications after 15 OCT 2018... Please update to this version ASAP..

For LiteSabre members only. To join, you must be an American Airlines crew-member, and have a valid LiteSabre account. Qualified crew-members may join LiteSabre at www.aapocket.com. (Currently, only legacy AA pilots are invited to join LiteSabre. This restriction is due to technical limitations only).
Read more
Collapse
5.0
19 total
5
4
3
2
1
Loading...

What's New

Bug fix for Android Oreo phones. Please contact LiteSabre support if you have any issues.
Read more
Collapse

Additional Information

Updated
September 23, 2018
Size
Varies with device
Installs
1,000+
Current Version
Varies with device
Requires Android
Varies with device
Content Rating
Everyone
Permissions
Offered By
Forty Foot Designs, LLC
©2019 GoogleSite Terms of ServicePrivacyDevelopersArtistsAbout Google|Location: United StatesLanguage: English (United States)
By purchasing this item, you are transacting with Google Payments and agreeing to the Google Payments Terms of Service and Privacy Notice.