TelInfo
(143)

Reviews

What's New
Info added in case the device appears to not support the required native Google API
Cant work on some Samsung devices from Android version 4.3
You can double check trying the USSD code *#*#4636#*#* manually

Similar

More from developer