CVTz50 DEMO

CVTz50 DEMO verifies compatibility of CVTz50 with specific ELM327 adapter and vehicle.
In case of successful connection with electronic control units, CVTz50 DEMO shows engine temperature, CVT temperature and list of supported CVTz50 features

Hardware requirements:
- Phone or tablet running Android 4.2+
- Bluetooth or WiFi adapter ELM327 revision 1.5 or lower (functionality might be significantly limited if used with not genuine adapters of revision 2.0+)
Read more
Collapse
4.6
363 total
5
4
3
2
1
Loading…

What's New

Improved stability and compatibility with new ELM327 devices
Read more
Collapse

Additional Information

Updated
November 28, 2021
Size
4.8M
Installs
50,000+
Current Version
1.54
Requires Android
4.0 and up
Content Rating
Everyone
Permissions
Offered By
cvtz50.info
Developer
©2022 GoogleSite Terms of ServicePrivacyDevelopersAbout Google Play|Location: United StatesLanguage: English (United States)
By purchasing this item, you are transacting with Google Payments and agreeing to the Google Payments Terms of Service and Privacy Notice.