Deltek Touch for Maconomy

103

The best way for on-the-go Deltek Maconomy users to not only submit, track and approve time and expenses but also approve vendor invoices, purchase orders, and even draft client invoices. Even when you are away from the office, immediate phone or tablet access means Deltek Touch for Maconomy keeps you informed and in control.

Device Requirements: Deltek Touch requires Android 7 or higher.

Deltek Maconomy Requirements: Deltek Touch is available for Deltek Maconomy clients on Maconomy 2.5, Maconomy 2.4 (GA or higher), Maconomy 2.3 (GA or higher) and Maconomy 2.2 (GA or higher).

Note: Deltek Touch requires a server-side component installed on the application server. Prior to using the mobile application, contact your IT department to ensure your Deltek Maconomy system meets all the requirements.

Access: Your Deltek Maconomy system must be accessible via the Internet. For setup information and systems requirements, see the documentation found on the Deltek Customer Care Connect site. For information about Customer Care Connect access, contact your internal Deltek Maconomy administrator.

Licensing: Deltek Touch requires a Deltek Maconomy Touch license. For more information, visit the Deltek corporate Web site or contact your Deltek representative.
Read more
Collapse
1.5
103 total
5
4
3
2
1
Loading…

What's New

This release fixes a bug in the PIN login screen.
Read more
Collapse

Additional Information

Updated
September 24, 2020
Size
4.6M
Installs
10,000+
Current Version
3.5.2
Requires Android
7.0 and up
Content Rating
Everyone
Permissions
Offered By
Deltek
Developer
2291 Wood Oak Drive Herndon, Virginia 20171-2823
©2020 GoogleSite Terms of ServicePrivacyDevelopersArtistsAbout Google|Location: United StatesLanguage: English (United States)
By purchasing this item, you are transacting with Google Payments and agreeing to the Google Payments Terms of Service and Privacy Notice.