Translate the description into English (United States) using Google Translate?Translate the description back to Finnish (Finland)

Uusittu ohjaussovellus Neurosonic-laitteille. Mahdollistaa laitteen käytön kaikilla yhteensopivilla puhelinmalleilla. Minimivaatimuksena bluetooth v4.0. Wifi-mallin Neurosonic-laitteet eivät vielä tuettuja.
The control application remodeled Neurosonic devices. Allows the use of the device with all compatible phone models. The minimum requirement bluetooth v4.0. Wi-Fi model Neurosonic devices are not yet supported.
Read more
Collapse
4.2
6 total
5
4
3
2
1
Loading...

Additional Information

Updated
August 4, 2018
Size
35M
Installs
500+
Current Version
1.8.08
Requires Android
4.4 and up
Content Rating
Everyone
Permissions
Offered By
Oy Neurosonic Finland Ltd
©2018 GoogleSite Terms of ServicePrivacyDevelopersArtistsAbout Google|Location: United StatesLanguage: English (United States)
By purchasing this item, you are transacting with Google Payments and agreeing to the Google Payments Terms of Service and Privacy Notice.