JBL Connect

The JBL Connect app works with JBL Flip 5, Flip 4, Flip 3, Charge 4, Charge 3, Pulse 3, Pulse 2, Xtreme 2, Xtreme and Boombox. Use the JBL Connect app for speaker configuration and software upgrade. iPhone 5 or newer is required for compatibility with JBL Pulse 3 and Pulse 2.
Read more
Collapse
2.9
19,773 total
5
4
3
2
1
Loading...

What's New

Supports JBL Flip 5
Read more
Collapse

Additional Information

Updated
July 3, 2019
Size
65M
Installs
1,000,000+
Current Version
4.5.223
Requires Android
5.0 and up
Content Rating
Everyone
Permissions
Offered By
Harman Consumer, Inc.
©2019 GoogleSite Terms of ServicePrivacyDevelopersArtistsAbout Google|Location: United StatesLanguage: English (United States)
By purchasing this item, you are transacting with Google Payments and agreeing to the Google Payments Terms of Service and Privacy Notice.